Back to overview
Some services are down
Sep 23 at 03:11pm GMT-3
Affected services
anticheat.ac
Resolved
Sep 23 at 03:11pm GMT-3
No down
Affected services
anticheat.ac
Resolved
Sep 23 at 03:11pm GMT-3
No down
Affected services
anticheat.ac